01635 500 315hi@squelch.itlowemasterpro

Squelch Unspam: Free Anti-Spam Plugin for WordPress

Unspam by Squelch Design is the simplest plugin you can find for reducing your comment spam problem. Once installed there’s nothing to configure, the plugin just quietly protects your WordPress website from spam.

Welcome to the official home page of the Squelch Unspam project, the simplest free anti-spam plugin for WordPress. Reduce your comment spam problem by simply installing this plugin.

Unspam by Squelch Design is the simplest plugin you can find for reducing your comment spam problem. Once installed there’s nothing to configure, and nothing changes to your visitors: No “CAPTCHA” or silly games. Once installed the plugin will simply randomise the names of the fields in the comments form on your blog and the reviews form in your WooCommerce shop, and reject comments that are sent to the standard WordPress field names, or where bots have blindly submitted data to the honeypot fields.

What this means for spammers is that they have to do quite a lot more work to send spam to your website. It may also make sending spam to your website unreliable as changes to your theme may upset their spam submission tools. Or they may have to resort to using humans to send spam to your website (not much I can do about that I’m afraid) which will cost them more money.

This is a set-and-forget plugin. Out of the box it will start reducing your comment spam without the need to change a single setting.
Currently implemented
  • Names of fields are randomized every night at 12:00
  • Submissions to the standard WordPress field names are automatically deleted
  • Honeypot fields added to comments form
  • WooCommerce support
Planned
  • Contact Form 7 integration
  • Statistical collection
  • Automated blocking of persistent IPs
  • Opt-in centralized collection of comment spam and statistics for additional research

 

Notices

Notice: Version 1.3 onwards requires JavaScript

Notice: Version 1.3 Onwards

As of version 1.3 of the plugin your website visitors will need JavaScript enabled in order to submit a comment.

Notice: Updating from 1.0 to 1.0.1 or later

Notice: Updating From 1.0 To 1.0.1 Or Later

Please note that on update WordPress will deactivate the plugin with an error message. You can safely reactivate the plugin, the error is merely due to the plugin file being renamed. WordPress cannot find the original file and so deactivates the plugin.